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INSTALLING THE R ENVIRONMENT ON YOUR
COMPUTER

WITH OPTIONAL INSTRUCTION TO INSTALL THE TINN-R EDITOR AND THE RCMDR
MENU INTERFACE

INSTALLING BASIC R

e The main website of R is http://www.r-project.or

e Todownload R go to http://cran.hostingzero.com/bin/windows/base/

e (lick R-2.6.1-win32.exe and select Run

File Download - Security Warning x|

Do you want to run or save this file?

MName: R-2.2,1-4in32.8x8
Type: Application, 26.2 MB

Fiom: cran hostingzero.com

B sae | [ Eaca |

While s from the Intemet can be useful, tis fle type can
potentiall ham yaur computer. |f wou da net trust the source, da nat
n or save this software. What's the risk?

e Select Run in this warning box:

Internet Explorer - Security Warning x|

The publisher could not be verified. Are you sure you want to run this
software?

Mame: R-2.2.1-wind2.exe

Publisher: Unknown Publisher

This file does not have a vaid diaital sianature that verifies its publisher, You
shoukd oy run software Fram publishers you trust, How can [ decide what
software bo run?

e Choose all the defaults. However, if you want to have additional information the
select “PDF Reference Manual” in the Setup window.

SIS E]
Select Components
‘Wwhich components should be installed? R

Select the components you want 1o install; clear the camponents pou da not wan! ta
install. Click Next when you are ready ta confinue.

[Custom instalation =]
Source Package Installation Files 1.2MB |
Support Fles for Package otk 54MB
Does for Packages gid and survival 1.5MB
Msssags Translalions 32MB

1 ersion for East Asian languages 22MB

[ Late: Help Files 26MB
PDF Reference b anual

O Source Files for Help Pages 1.4MB

Cunert selection requies at lesst 51.4 MB of disk space.

< Back I Mt > I Cancel
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e Start R by clicking on its desktop icon or selecting it from the start menu

File Edit Msc Packages Windows Help

R : Copyright 2005, The R Foundation for Statistical Computing
Version 2.2.1 (2005-12-20 r36812)
ISEN 3-900051-07-0

R is free software and comes with ABSOLUTELY NO WARRANTY.
¥ou are welcome to redistribute it under certain conditions.
Type 'license()' or ‘'licence(]' for distribution details.

Natural language support but running in an English locale
R is & collsborative project with Wany contributors.

Type 'contributors()' for wore information and

‘citation(}' on how to cite R or R packages in publications.
Type 'demo(]' for some demos, 'help()' for on-line help, or

‘help.start()' for an HTHL browser interface to help.
Type 'g{)' to gquit E.

& |

R 2.2.1- ALanguage and Enviranment

INSTALLING R PACKAGES

e You may want to install additional packages which are program libraries that extend
the functionally of R. First you need to download these packages from a CRAN web
server:

e Select Packages » Install Packages()...
e You can select any download mirror [Note that the “USA (TX)” download site is not

always stable. Should you encounter problems select another site in the USA]:

Tkaly [Fenara] =
IKaly (Milano)

Italy (Palerma)

lsrael

[Japan [Aizu)

Japan [Tsukuba)

Korea

Netherlands

Poland (Lublin)

Poland fwaclaw)

Poitugal

Slovenia [Besnica)

Slowenia [Livblianal

South Affica (Cape Town)

South Alica (Grahamstown)
Spain

Suwitzenland (Zuerich]

Switzerland (Bem 1)

Suitzerland [Bein 2)

Turkey
Taivan [Taichung)
Taivan [Taipeh]
UK [Bristal]

UK [London]

Usa
LS4 [P, 2]

UISA [wia) =

0K Cancel
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o The “foreign” package allows you to import rectangular data files from several other

software packages such as Dbase, SPSS, SAS or Stata files.

FLCore -
flexchist

Flewris:

fMultivar

fOptions:

fortunes
fonward

fpe
fPortfolio
fracdift

frailtypack J
fSenes

ftnonpar
fuzzyRankTests
gdata

gafit

gam

gamair

ganlss
GammaT est

gap

gap (gap)
gbm
atlus
gemies
gdata
ge2
gespack
gendlg
Geneland
GeneNT
gerietics
GeneT5

Gerkem -
k. Cancel

e Inorder to use a package in a current session you would need to load it. You can do
this either at the command prompt by entering and submitting

0 > library(foreign)
0 or thru the menu Packages » Load package ... » Select one » foreign

Attention: Commands and variable names in R are case sensitive (i.e., foreign is
different from Foreign)

e Ifyouneed help or code examples you can go to the html help facility:
Help » Html help

) The R Language - Microsoft Internet Explorer =10l x|
Be ER ew Faporder Lok el o
Qe - ) - [¥] [B] (| S sewn oo &) (- 05 - S G B
Adress i8] C-\Pregpam FiesiR1R-2.2. docinemiywn himl 2 B e |k -
=
Statistical Data Analysis @
Manuals
An Intraduction to B Wiritng B Estensions
The B Language Definition E Data ImportExpart

R Insallasion and Administration

Reference

Packages

About B Eesources

License Thamks

5 S B e L
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Select for instance Packages to find information on the “foreign” library

3 R: Read Data Stored by Minitab, 5, SAS, SPSS, Stata, Systat, dBase, ... - Microsoft Internet Explorer _|of x|

Fle Edt  View Favorites Tools  Help | o
A ® I Z R 20

Qo - © - [x) (B B[ L Syrone @[22 - 3 B

Address [ Ci\program FiesiR\R-2.2.1\braryiforeigrihtrl|00Indes. herl I Ee |L\nl6 >y -

Read Data Stored by Minitab, S, SAS, SPSS, Stata,

Systat, dBase, ...

>

Documentatiocn for package “foreign' version 0.8-12

Help Pages

data.restore Read an 53 Binary File

lockup . zport Lookup Information on a 343 JPORT Format Library

read dbf Eead a DEF File

read.dta Read Stata Binary Files

read.epiinfo Read Epi Info Data Files

read mty Eead a Minitab Portable Worlcsheet

read. octave Read Qctave Test Data Files

read.2 Read an 33 Binary File

read spes Eead an PSS Data File

read.ssd Obtain a Data Frame from a SAS Permanent Dataset, via read. zport

read systat Obtain a Data Frame from a Systat File

read.xport Read a SAS HPORT Format Library

write. dbf Write a DBF File

write. dta TWrite Files in Stata Binary Format

write. foreion Write Text Files and Code to Read Them

=l

[&] Done [T [ 5 My Computer W

BAsIc CODE EDITOR IN R

¢ Ronly comes with a very rudimentary code editor in the file menu

File » New Script
=loix|

Fle Edt Packages Windows Help
[Fun line or selection 4]
‘citatiom ©h Bow to cite R or B packages in publications.

Type 'demo{}' for some demos, ‘helpi)' for on-line help, or
‘help.stert ()’ for en HTML browser interface to help.
Type 'gi)' to gquit R,

> utils::imenuInstallPkysi)

--- Please select a CRAN mirror for use in this session -—

teying URL ‘http://cran.hostingzero.com/bin/windovs/contrib/z.2/forsign 0.6-12.4
Content type 'application/zip' length 187811 bytes

- Untitled - R Editor -[ox

librery (foreign)

« >

I 4

This editor allows you to run selected lines of code directly in R.

Version March 2008 by Michael Tiefelsdorf - The University of Texas at Dallas



Installing R on your computer

INSTALLATION OF A BASIC MENU SYSTEM

o Copy the file Rprofile.site into the directory C:\Program Files\R\R-2.6.1\etc)\ (note,
it will overwrite the existing profile).
The next time you start R the menu system will be installed automatically.
To start the menu system type at the R’'s command prompt

0 > library(Rcmdr)
The instructions below explain the manual installation procedure of the Rcmdr.
e Download the package Rcmdr. Remember:
0 Select menu Packages » Install Package(s) ...
0 Pick adownload server-site

0 Select Rcmdr from the download dialog

rattle -
rbugs

rodk

RColorErewer

rcom

rcompigen

RcppTemplate

0 When you download the Remdr several other packages, such as the foreign
package, are downloaded in addition if they are not already installed in a
prior session. The Rcmdr uses these packages.

To start the Remdr issue at the command prompt either
e > library(Rcmdr)
e Or select the menu Packages » Load Packages ... and pick form the list the Remdr

e Before the Remdr interface opens additional packages may be downloaded
automatically. This may take a few minutes.
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o This opens the R Commander menu system window

Il

File Edit Data Statistics Graphs Models Distributions Tools Help

:agﬂ.l Data set:| <Mo active datasets | Edit data setl Yiew data setI Madel: | <No active model>

Script Window

=l
-
| ,
Dutput Window Submit]
|

o o

Messages

NOTE: B Commander Version 1.2-5: Mon Jan 08 16:13:20 2007
>
o] 3

You should not have warning messages in the Messages window.

o To get help on the Remdr select its Help menu.

INSTALLATION OF AN ADVANCED EDITOR

e A more comfortable editor that can be seamlessly integrated into R is the shareware
editor Tinn-R (download at http://www.sciviews.org/Tinn-R/)

e Download and install Tinn-R form the above site.
e To integrate Tinn-R seamlessly with the R environment adjustments are required:

The latest version of Tinn-R does not run in the MDI mode of the R interface. To
disable the MDI mode goto Edit » GUI-preferences ... in the R-menu and select the

SDI option
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Rgui Configuration Editor

Single or mulkiple windows ¢ mpr [#| 10T tolar I¥ | (DT skatustiar
Pager skyle & multiple windou Language for menus I:I

) ) and messages
 single window

Fonk I Courier Mew Vl ¥ TrueType only size n - style Inormal 'l

Console  rows columnns Initial left EI top
[ set options{width) on resize? buffer bytes [ 5000 lines 3000

|+ buffer console by default?

Pager rows columns
Graphics windows: initial left top EI

Caonsole and Pager Colours

Backgraund Oukput bext User input Titles in pager

wheat3 - Mavajowhite o purple3 . Darkorchid3 -
wheatd Mavajowhited Urpled DarkOrchids
- - - -
Apphy | Save | Load | QK | Cancel |

Select Save and accepted the suggest filename and location.
You can close the Rgui Configuration Editor now.
Close and restart R.

o Copy the file Rprofile.site file into the directory C:\Program Files\R\R-2.6.1\etc\
(note, it will overwrite the existing profile). The next time you start R, the editor
Tinn-R will be automatically linked with the R environment and opened
automatically.

The instructions below explain the manual installation procedure for Tinn-R if you plan not
to use the provided file Rprofile.site:

e The packages

= SvIDE,

= SvSocket,
= SvIO and
= R2HTML

have to be downloaded from one of the R-library servers.

e The profile file profile.site in the R Program Files directory (see C:\Program
Files\R\R-2.6.1\etc\) needs to be edited by adding these lines:

options(IDE ='C:/Program files/Tinn-R/bin/Tinn-R.exe")
options(use.DDE = TRUE)

library(svIDE)

library(svSocket)

library(svIO)

library(R2ZHTML)

guiDDElInstall()
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Just copy above lines and past them to the end of profile.site file.

¢ You find more information in the Tinn-R Help menu under the topic “Tinn-R and
R Configuration”.

NOTE FOR WINDOWS VISTA USERS:

WINDOWS VISTA is much stricter than WINDOWS XP when it comes to security issues. Since
help files of downloaded and/or updated R-libraries want to manipulate R’s protected
HTML setup, they will not install without turning off first the User Account Control (UAC). In
order to do this:

1. Go to Control Panel » User Accounts » Turn User Account Control » Off

Make changes to your user account
Create a password reset disk

Manage your network Create a password for your account

passwords Change your picture g "7l Michael

Manage your file encryption @ Change your account name Administrator

certificates

'@' Change your account type
Configure advanced user
profile properties

Change my environment @
variables ¢ & Turn User Account Control on or off
¥

—_—

You will be asked whether you would like to continue this task. Choose Continue,
unselect Use User Account option and click OK in the dialog window below:

% <« Turn User Account Contr... - Search

File Edit View JTools Help

Turn on User Account Control (UAC) to make your computer more secure

User Account Control (UAC) can help prevent unauthorized changes to your computer, We recommend that

youtsave UAC turned on to help protect your computer,
UseJser Account Control (UAC) to help protect your computer
N

Gone

2. Windows Vista needs to be rebooted for these changes to take effect. Reboot now
3. Open R and issue at the command prompt the line link._html _help() and hit
return. This will update the help system of the download and/or update libraries.
4. If you want to enable UAC again, go to
Control Panel » User Accounts » Turn User Account Control » On
to turn UAC on again.
5. Re-boot WINDOWS VISTA for the change to take effect
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